GLPI Fusioninventory Debian Wheezy Samba 4

Prérequis

Prérequis nécessaires à l’installation de GLPI.
GLPI utilise les technologies suivantes :
• PHP pour le langage ;
• MySQL pour la base de données ;
• HTML pour les pages web ;
• CSS pour les feuilles de style ;
• CSV, PDF et SLK pour les exports de données ;
• AJAX pour les éléments dynamiques de l’interface ;
• SVG et PNG pour les images et les graphiques.
Prérequis du serveur web
Caractéristiques du serveur web nécessaires pour faire fonctionner GLPI.
Serveur web
GLPI nécessite un serveur web supportant PHP tels que :
• Apache 2 ou supérieur (http://httpd.apache.org) ;

PHP
GLPI nécessite PHP version 5.3 ou supérieure (http://www.php.net).
Extensions PHP obligatoires
Les extensions PHP suivantes sont nécessaires au bon fonctionnement de l’application :
• JSON : support du format de données structuré JSON ;
• Mbstring : gestion des chaînes de caractères multi-octets ;
• MySQL : liaison avec la base de données ;
• Session : support des sessions des utilisateurs.
Extensions PHP facultatives mais recommandées
Les extensions suivantes sont requises pour des fonctionnalités optionnelles de l’application :
• CLI : utilisation de PHP en ligne de commande pour les actions automatiques ;
• CURL : pour l’authentification CAS ;
• DOMXML : pour l’authentification CAS ;
• GD : génération d’images ;
• IMAP : utilisation de serveurs de messagerie pour la collecte des tickets ou l’authentification des utilisateurs ;
24 | Documentation utilisateur pour GLPI 0.83 | Déployer GLPI
• LDAP : utilisation d’un annuaire externe pour l’authentification ;
• OpenSSL : communication chiffrée.

 

 

apt-get install apache2 php5 php5-gd php-pear php5-imap php5-ldap php5-curl php5-mcrypt

apt-get install mysql-server php5-mysql

apt-get install libapache2-mod-perl2

/etc/init.d/apache2 reload

mysql -u root -h localhost -p
create database db_glpi;
create user u_glpi@'localhost' identified by 'pwdglpi';
grant all on db_glpi.* to u_glpi@'localhost';
flush privileges;
quit

 

cd /tmp

wget https://forge.indepnet.net/attachments/download/1466/glpi-0.83.8.tar.gz

tar -xvzf glpi-0.83.8.tar.gz -C /var/www

chown -R www-data /var/www/glpi

 

root@glpi:/tmp# grep memory_limit /etc/php5/apache2/php.ini
memory_limit = 128M

 

francais /localhost/u_glpi/glpi/db_glpi

 

Selectionner preconfiguration pour Active Directory

 

root@glpi:/tmp# dpkg -l | grep mysql
ii libdbd-mysql-perl 4.021-1+b1 amd64 Perl5 database interface to the MySQL database
ii libmysqlclient18:amd64 5.5.31+dfsg-0+wheezy1 amd64 MySQL database client library
ii mysql-client-5.5 5.5.31+dfsg-0+wheezy1 amd64 MySQL database client binaries
ii mysql-common 5.5.31+dfsg-0+wheezy1 all MySQL database common files, e.g. /etc/mysql/my.cnf
ii mysql-server 5.5.31+dfsg-0+wheezy1 all MySQL database server (metapackage depending on the latest version)
ii mysql-server-5.5 5.5.31+dfsg-0+wheezy1 amd64 MySQL database server binaries and system database setup
ii mysql-server-core-5.5 5.5.31+dfsg-0+wheezy1 amd64 MySQL database server binaries
ii php5-mysql 5.4.4-14 amd64 MySQL module for php5

 

ressources :

 

http://www.reseaucerta.org/docs/cotelabo/coteLaboOcsGlpi.pdf

 

On récupère les fichiers sur http://forge.fusioninventory.org/projects/fusioninventory-for-glpi/files

cd /tmp
wget http://forge.fusioninventory.org/attachments/download/952/fusioninventory-for-glpi-metapackage_0.83+2.2.1.tar.gz

le plugin WebService pour GLPI est nécessaire pour l’utilisation du déploiement :

https://forge.indepnet.net/projects/webservices/files :

wget https://forge.indepnet.net/attachments/download/1205/glpi-webservices-1.3.1.tar.gz

Remarque ;
Mise à jour

Vous devez en PREMIER désactiver le plugin FusionInventory For GLPI et déplacer les dossiers du plugin FusionInventory for GLPI. Cela pour être que les fichiers obsolètes seront proprement enlevés.
Décompresser l’archive dans le dossier plugins de GLPI:

tar -xzvf glpi-webservices-1.3.1.tar.gz -C /var/www/glpi/plugins
tar -xzvf fusioninventory-for-glpi-metapackage_0.83+2.2.1.tar.gz -C /var/www/glpi/plugins

cd /var/www/glpi/plugins
chown -R www-data.www-data fus*

Deploiment par GPO :

http://www.fusioninventory.org/documentation/agent/installation/windows/large_install/

Une réflexion au sujet de « GLPI Fusioninventory Debian Wheezy Samba 4 »

Laisser un commentaire